The Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by NCTM or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.matlab

Notice: We are no longer accepting new posts, but the forums will continue to be readable.

Topic: Problem with movie-command
Replies: 6   Last Post: Nov 17, 2011 9:08 AM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
Steven Lord

Posts: 18,038
Registered: 12/7/04
Re: Problem with movie-command
Posted: Nov 16, 2011 9:09 AM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply



"Martina " <sir.henry2@gmx.net> wrote in message
news:ja0cea$82d$1@newscl01ah.mathworks.com...
> Oh, and another question:
>
> Suppose that I use several 'plot' commands for each frame. Normally I
> would use hold on/off to get the plots into the same figure; however, that
> doesn't work right here, because here plots from previous frames stay
> visible.
> Is there some other way for making several plots in one frame?


Inside your loop:

hold on
% run your plots
% collect your movie frame
cla % or DELETE the lines you plotted using the handle output arguments from
PLOT

--
Steve Lord
slord@mathworks.com
To contact Technical Support use the Contact Us link on
http://www.mathworks.com




Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© The Math Forum at NCTM 1994-2018. All Rights Reserved.