The Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by NCTM or The Math Forum.


Math Forum » Discussions » sci.math.* » sci.math.symbolic

Notice: We are no longer accepting new posts, but the forums will continue to be readable.

Topic: Terrible algebraic system
Replies: 18   Last Post: Mar 8, 2012 4:26 AM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
clicliclic@freenet.de

Posts: 1,245
Registered: 4/26/08
Re: Terrible algebraic system
Posted: Feb 24, 2012 5:35 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply


deltaquattro@gmail.com schrieb:
>
> Hmmm! Tried following this approach, i.e. solving f(b)=0 with Netwon's
> and then plugging b in a=g(b), but it doesn't work. The solution
> doesn't satisfy the initial system. Try for example
>
> L=-1
> U=1
> p=0.0013498980316301
>
> I get
>
> a=-1
> b=1
>
> which clearly is wrong, i.e., a and b don't solve the initial system,
> even though f(b)=f(1)=0 and a=g(b)=g(1)=-1. I rewrite the initial
> system here:
>
> ((a-L)^2/a)*(2/(a+b))-p=0
> ((b-U)^2/b)*(2/(a+b))-p=0
>
> Am I doing something wrong, or is FriCAS/Derive solution wrong?


Here are two cases solved numerically on Derive 6.10. I am employing
NSOLUTIONS rather than SOLUTIONS to avoid the solution of the quartic in
terms of radicals. Because the solutions are very close-spaced here, I
calculate with 50 decimal digits, but display only 20.

VECTOR([(2*b^3*(p-1)*(p-2)+2*b^2*(L*p*(p-2)-U*(p^2-8*p+8))+b*(L^~
2*p^2+8*L*U*p+4*U^2*(5-3*p))-4*U^2*(L*p+U*(2-p)))/(U^2*p*(p-2)),~
b],b,NSOLUTIONS(b^4*(2*p^2-6*p+4)+b^3*(L*(2*p^2-4*p)-U*(2*p^2-16~
*p+16))+b^2*(L^2*p^2+8*L*U*p+U^2*(p^2-16*p+24))-b*(4*L*U^2*p+U^3~
*(16-8*p))+U^4*(4-2*p)=0,b))

[PrecisionDigits:=50,NotationDigits:=20,Notation:=Scientific]

[L:=0.25,U:=0.75,p:=0.01]

[[0.29007577868013072549,0.81726799481696407429],[0.216579860409~
31767338,0.81482327019556370466],[0.2875217077905326939,0.691798~
12606618555515],[0.21843622603509935998,0.69374930746450782216]]~

[L:=0.25,U:=0.75,p:=0.001]

[[0.23902035037776225359,0.76970301260431589968],[0.261616119176~
58470495,0.76992754219499544002],[0.23922634759198693214,0.73116~
497741918571842],[0.26138830891719837594,0.73095584397009773977]~
]

Maxima should allow to do the same.

Martin.



Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© The Math Forum at NCTM 1994-2018. All Rights Reserved.