Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: Mathematica 9: bug in merging cells
Replies: 5   Last Post: Dec 7, 2012 1:36 AM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
Rafapa

Posts: 1
Registered: 12/5/12
Re: Mathematica 9: bug in merging cells
Posted: Dec 5, 2012 3:11 AM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

On Tuesday, December 4, 2012 10:09:37 AM UTC+1, Fred Simons wrote:
> When writing a larger program, I usually test the single steps in
>
> separate cells, then merge these cells and localize the variables by
>
> wrapping the contents of the merged cells in a Module. By doing so in
>
> Mathematica 9, due to a bug in merging cells, I lost a lot of code. I
>
> reported this bug to WRI two weeks ago. It is not yet repaired in the
>
> new release, so I thought I would mention this annoying bug here as well.
>
>
>
> This is an example (Mathematica 9 for Windows, I am not aware if this
>
> happens for other systems too).
>
>
>
> Construct two input cells, the first one containing
>
>
>
> a=1;
>
> (* comment *)
>
> b=2;
>
>
>
> and the second one
>
>
>
> c=3;
>
>
>
> When merging these two cells the contents ending with the comment is
>
> shown in an orange rectangle, with the error message that there is a
>
> RowBox with an invalid first argument. I cannot see any reason why this
>
> merging of cells could not be undone with ctrl-Z, but it cannot and
>
> therefore part of my code was gone.
>
>
>
> In this simple example I could see how to fix it. Toggle ctrl-E for
>
> seeing the box structure. Place a } just behind the RowBox with the
>
> comment and a { behind the very first RowBox[, that is followed on the
>
> next line with another RowBox.
>
>
>
> During writing this message, I found that the same happens when you try
>
> to copy and paste the first cell.
>
>
>
> Fred Simons
>
> Eindhoven University of Technology


Same problem with Mathematica 9.0.0 under Linux x86 (64 bit).

Rafael R. Pappalardo
Univ. of Seville (Spain)




Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.