Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.matlab

Topic: matlab 2011a not installing on windows 8
Replies: 1   Last Post: Jan 18, 2013 2:51 AM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
justsomeguy

Posts: 1
From: United States
Registered: 1/18/13
Re: matlab 2011a not installing on windows 8
Posted: Jan 18, 2013 2:51 AM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

While this topic has been abandoned, I thought I'd post how I resolved this issue for the benefit of any others with this same issue. I know when I was google'ing for a solution, I was crestfallen to find this topic but see no fix posted.

I am using Windows 8 64-bit. However, I was attempting to install Matlab R2012b on my system, NOT R2011a, so no guarantees that this is a universal solution, but I kept getting error "2" from above, verbatim, in which "...\jvm.dll is either not designed to run on windows or it contains an error..."

To quickly state how I fixed this problem: I had to reformat Windows 8. Reinstalling Matlab R2012b after this went just fine with no errors during installation. It's up and running without any problems.

For extra context: Before my first attempt at installing R2012b, I'd tried installing my older version of R2010a, since I prefer the layout and was most familiar with it. Unfortunately Windows 8 would not support it. I was able to install it but couldn't get it to start-up, even after messing with the different compatibility options. I performed a system restore to a point prior to this Matlab install. I, then, tried to install Matlab 2012b (it's newer and is provided by my school but also requires a vpn to use. My R2010a version was older but I had purchased it on my own, so no vpn was necessary, making it more convenient, personally). I, then, got the error message described above, so I thought the old, R2010a JVM wasn't completely removed and was gumming up the works. After going through my computer and trying to remove any and all JREs and JDKs (to remove any old remnants from the R2010a JVM), I still couldn't install and would get the same error message every time. Using CCleaner to remove any potential remnants in the registry did not help, nor did clearing out the entire "temp" folder. Reformatting Windows 8 was the only thing that did the trick. If you're more knowledgeable about computers than myself, you may be able to solve the problem without resorting to a reformat, but it's the only thing that worked for me. I can only guess that the R2010a JVM was the problem and that I wasn't successfully removing ALL of it and only a reformat was able to.

I don't know any of OP's specifics, except for what he/she has provided above, but I'm guessing that he had an old JVM (from a former Matlab version) still on his computer that was causing problems with the newer JVM provided with the newer version of Matlab.

Maybe this will help someone else out there; maybe it won't, but here's to hoping that this will spare you some of the headaches that I had to suffer through.



Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.