Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: Problem in solving Differential Equation
Replies: 3   Last Post: Mar 28, 2013 5:12 PM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
Bob Hanlon

Posts: 895
Registered: 10/29/11
Re: Problem in solving Differential Equation
Posted: Mar 28, 2013 5:12 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

You have addressed different problems in this one thread and it is
unclear to which problem you are currently having problems. You have
not provided any of your code so I cannot say why you are getting
error messages. I obviously don't have a problem with the code that I
sent.

If you are putting multiple Manipulate statements in the same notebook
that use the same symbol names they are probably interacting with each
other. Use Module inside each Manipulate to constrain the scope of
definitions, or use different symbol names in the different Manipulate
statements.


Bob Hanlon


On Thu, Mar 28, 2013 at 4:06 AM, Rahul Chakraborty
<rahul.6sept@gmail.com> wrote:
> Sir,
>
> Its not giving output. The following error its showing
>
> ERROR: Set::write: : Tag List in {150 Cos[15 t]+5.` Sin[15
> t]==0,False}[t_] is Protected.
>
> DSolve::dsfun: "10\ Sin[15\ t] cannot be used as a function."
>
> ReplaceAll::reps: "{150\ Cos[15\ t]+5.\ Sin[15\ t]==0,False} is
> neither a list of replacement rules nor a valid dispatch table, and so
> cannot be used for replacing"
>
>
>
> These ERROR messages are coming repeatedly.
>
>
>
> Regards,
>
> Rahul
>
> On 3/28/13, Bob Hanlon <hanlonr357@gmail.com> wrote:

>> Your DE can be solved exactly using DSolve.
>>
>> Manipulate[
>> eqn = x'[t] + lambda*x[t] == 0;
>> sol[t_] = x[t] /. DSolve[
>> {eqn, x[0] == 1/2}, x[t], t][[1]];
>> ParametricPlot[
>> {sol[t], sol'[t]},
>> {t, 0, 25},
>> PlotRange -> {{-0.1, 0.6}, {-3, 0.5}},
>> Frame -> True,
>> Axes -> False,
>> FrameLabel -> (Style[#, "Courier", Bold, 16] & /@
>> {x, Overscript[x, "."]}),
>> AspectRatio -> 1,
>> PlotStyle -> {{Red, AbsoluteThickness[2]}}],
>> {{lambda, 0.5}, 0, 5, 0.01, Appearance -> "Labeled"}]
>>
>>
>> Bob Hanlon
>>
>>
>> On Wed, Mar 27, 2013 at 11:29 PM, Rahul Chakraborty
>> <rahul.6sept@gmail.com> wrote:

>>> Sir,
>>>
>>> Can you kindly see what is the mistake in this code of mine. Its not
>>> giving me the output.
>>>
>>>
>>> Clear [x,t];
>>> eqn=x'[t]+lambda*x[t]==0;
>>> Manipulate[[sol_]=NDSolve[{eqn,x[0]==1/2},x[t],{t,0,50}][[1]];
>>> ParametricPlot[Evaluate[{x[t]/.sol,D[x[t]/.sol,t]}],{t,0,25},PlotRange-=

>{{-20,20},{-25,25}},Frame->True,Axes->False,FrameLabel->(Style[#,"Courier"=
,Bold,16]&/@{"x",Overscript[x,"."]}),AspectRatio->1,PlotStyle->{{Red,Absolu=
teThickness[2]}}],{{lambda,0.5},0,5}]
>>>
>>>
>>>
>>> Sincerely,
>>>
>>> Rahul
>>>
>>> On 3/6/13, Bob Hanlon <hanlonr357@gmail.com> wrote:

>>>> Arguments to functions (e.g., Sin, Cos) must be enclosed in squares
>>>> brackets: Sin[x[t]] and Cos[x[t]]
>>>>
>>>> Clear[x];
>>>> \[Omega] = -2;
>>>> eqn =
>>>> x''[t] + Sin[x[t]] - \[Omega]^2 Sin [x[t]] Cos[x[t]] == 0 //
>>>> Simplify;
>>>> sol = NDSolve[
>>>> {eqn, x[0] == 1/2, x'[0] == 0},
>>>> x[t], {t, 0, 25}][[1]];
>>>> ParametricPlot[
>>>> Evaluate[{x[t] /. sol, D[x[t] /. sol, t]}],
>>>> {t, 0, 25},
>>>> Frame -> True,
>>>> Axes -> False,
>>>> FrameLabel -> (Style[#, "Courier", Bold, 16] & /@
>>>> {x, Overscript[x, "."]}),
>>>> AspectRatio -> 1,
>>>> PlotStyle -> {{Red, AbsoluteThickness[2]}}]
>>>> ParametricPlot[
>>>> Evaluate[{t, x[t] /. sol}],
>>>> {t, 0, 10},
>>>> Frame -> True,
>>>> Axes -> False,
>>>> FrameLabel -> (Style[#, "Courier", Bold, 16] & /@
>>>> {t, x}),
>>>> AspectRatio -> .5,
>>>> PlotStyle -> {{Green, AbsoluteThickness[3]}}]
>>>>
>>>>
>>>> Bob Hanlon
>>>>
>>>>
>>>> On Tue, Mar 5, 2013 at 10:14 PM, Rahul Chakraborty
>>>> <rahul.6sept@gmail.com> wrote:

>>>>> Dear all,
>>>>>
>>>>> Following differential equation seems to have some error in coding b=

y
>>>>> me.
>>>>> kindly let me know where i have gone wrong.
>>>>>
>>>>> Clear[x];
>>>>> \[Omega]:=-2;
>>>>> eqn=x''[t]+ Sin x[t]-\[Omega]^2 Sin x[t]Cos x[t]==0//Simpli=

f=
> y;
>>>>> sol=NDSolve[{eqn,x[0]==1/2,x'[0]==0},x[t],{t,0,1000}][[1]]
>>>>> ParametricPlot[Evaluate[{x[t]/.sol,D[x[t]/.sol,t]}],{t,0,25},Frame->T=

rue,AxesLabel->{"x",Overscript[x,"."]},AspectRatio->1,PlotStyle->{{Red,Abso=
luteThickness[2]}},TextStyle->{FontFamily->"Courier",FontWeight->"Bold",Fon=
tSize->16}]
>>>>> ParametricPlot[Evaluate[{t,x[t]/.sol}],{t,0,10},Frame->True,AxesLabel=
->{"t","x"},AspectRatio->.5,PlotStyle->{{Green,AbsoluteThickness[3]}},TextS=
tyle->{FontFamily->"Courier",FontWeight->"Bold",FontSize->16}]
>>>>>
>>>>> Regards,
>>>>>
>>>>> rahul
>>>>>

>>>>
>>
>




Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.