Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.matlab

Topic: Help with UNIX() command
Replies: 5   Last Post: Apr 5, 2013 10:43 PM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
John

Posts: 14
Registered: 2/17/11
Re: Help with UNIX() command
Posted: Apr 4, 2013 3:52 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

"Nasser M. Abbasi" wrote in message <kjkl4o$if2$1@speranza.aioe.org>...
> On 4/4/2013 2:26 PM, John wrote:
> > I want to run a shell script within MATLAB, but the script is csh. When I try running
> >it in MATLAB it says /bin/bash commande does not exist. How do I get MATLAB
> >to run the UNIX command using csh and not bash?
> >

>
> When you explain a problem, it helps to also show what you actually
> typed. No one can see your screen from here to figure what you
> typed.
>
> But may be this helps
>
> http://www.mathworks.com/help/matlab/ref/system.html
>
> "system
>
> Execute operating system command and return output"


[s,w]=unix('to3d -session e126 -prefx 4244_run_01 -epan -time:zt 28 104 1800 altplus ./s1037/*MRDC*')
/bin/bash: to3d: command not found

That is what I run and the error I get. Using system produces the same error. The problem is MATLAB is trying to run it through a bash shell, and its a command for a c-shell(csh). I need to know how to get MATLAB to execute the command in a c-shell. and ! will not work either for the exact same reason.



Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.