Date: Apr 19, 2012 1:24 PM
Author: kinor
Subject: Re: has any one got defun() to work on matlab 2010a?

"Yair Altman" wrote in message <jmp8ne$asv$1@newscl01ah.mathworks.com>...
> "kinor" wrote in message <jmoq2j$6qd$1@newscl01ah.mathworks.com>...
> > Hi
> > more questions on depfun:
> > I have several licences in use, a local where everything works fine and a network licence which i tested on several machines and after an hour i got:
> >

> > >> depfun('mesh')
> > Out of memory. Type HELP MEMORY for your options.
> >
> > ver gives
> > -------------------------------------------------------------------------------------
> > MATLAB Version 7.12.0.635 (R2011a)
> > MATLAB License Number: number..
> > Operating System: Microsoft Windows 7 Version 6.1 (Build 7601: Service Pack 1)
> > Java VM Version: Java 1.6.0_17-b04 with Sun Microsystems Inc. Java HotSpot(TM) Client VM mixed mode
> > -------------------------------------------------------------------------------------
> >
> > questions on the former posters:
> > do you have local or network licences?
> >
> > I am a bit astonished that this basic command causes problems in several versions of Matlab
> >
> > best kinor

>
>
> Try using the fdep utility on the File Exchange - it's faster, better and would probably not give you the error that depfun gives you:
> http://www.mathworks.com/matlabcentral/fileexchange/17291-fdep
>
> Yair Altman
> http://UndocumentedMatlab.com
> Read my Matlab-Java Programming book
>


Hi Yair,

thanks a lot for your advice.
I am surprised that TMW does not seem to fix the function.

best regards
Norbert