Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.matlab

Topic: Matlab 2007b with Fedora Core 6
Replies: 1   Last Post: Dec 14, 2007 12:39 PM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
David B. Chorlian

Posts: 173
Registered: 12/7/04
Re: Matlab 2007b with Fedora Core 6
Posted: Dec 14, 2007 12:39 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

In <b78c9095-0e62-41c3-96b8-dc78cea1bdc4@i12g2000prf.googlegroups.com> chzhzhang@gmail.com writes:

>Dear group,

>I just tried to install Matlab 2007b under FC6. The installation seems
>to be successful.
>But when I type "matlab" in the terminal, after the splash screen,
>only command line mode is invoked, same thing happens when I type
>"matlab -nodesktop", with the standard matlab greeting


>"To get started, type one of these: helpwin, helpdesk, or demo.
> For product information, visit www.mathworks.com."


>If I type "matlab -nojvm", then in addition to above it also shows the
>header
>
>< M A T L A B >
> Copyright
>1984-2007 The MathWorks, Inc.
> Version
>7.5.0.338 (R2007b)
>
>August 9, 2007
>in addition to the welcome message.


>It is really weird that no error message or error log is generated.

>In addition, if I moved the java folder in $matlabroot/sys/, and type
>"matlab" it pops up a warning
>---------------------------------------------------------------------------
>Warning: Cannot locate Java Runtime Environment (JRE) . . .


> 1. Either a correct JRE was not available for redistribution
>when
> this release was shipped, in which case you should refer
>to the
> Release Notes for additional information about how to get
>it.


> 2. Or you have tried to use the MATLAB_JAVA environment
>variable
> to specify an alternate JRE, but MATLAB cannot find it.
>Please
> run 'matlab -n' to determine what value you are using for
> MATLAB_JAVA and fix accordingly.
>---------------------------------------------------------------------------
>and still proceeds to the command line mode.


>When I type matlab -n, the MATLAB_JAVA variable is always empty, even
>if I set the environment variable to be the system java folder.


>Any help/suggestions will be appreciated.

Have you run ldd on the matlab binary?
Try using strace to run matlab; focus on the 'open()' calls.

>best,

>C.Z.
--
David B. Chorlian
Neurodynamics Lab SUNY/HSCB
chorlian@cns.hscbklyn.edu
davidc@panix.com



Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.