Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.matlab

Topic: Cell mode turned on, but code folding isn't working
Replies: 6   Last Post: Mar 5, 2014 3:41 PM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
James

Posts: 3
Registered: 6/22/09
Cell mode turned on, but code folding isn't working
Posted: May 12, 2010 1:01 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

Using R2010a and R2009b...

I have a large script m-file (~188k lines) auto-generated by COMSOL Multiphysics (a finite element solver). 99.99% of those lines are oddly formatted COMSOL data (which I can't easily read in from a mat file).

I would be content to wrap these data sections in cell tags (%%) and fold them while I work, but it's not working.

I have cell mode turned on for the file and I've gone into preferences to make sure that code folding is enabled for cells.

I have inserted %% cell tags in the appropriate places, but they are not collapsible. (There's no minus sign next to them. In fact none of the code - if or for loops - is collapsible.) When I click on the "Show Cell Titles" button in the Editor toolbar, it says "No Cell Titles Found". If I use the"Insert Cell Break" toolbar button, the Editor cannot find a new cell.

Is is simply the size of the file that's breaking this feature, or am I missing something else?

Thanks in advance!
-Jim H



Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.