Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: Shift-Ctrl-N and Manipulate
Replies: 2   Last Post: Dec 21, 2010 12:22 AM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View  
ברק שושני

Posts: 8
Registered: 12/19/10
Re: Shift-Ctrl-N and Manipulate
Posted: Dec 21, 2010 12:22 AM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

Thanks for the quick reply!

Ctrl-Shift did not solve it, but Edit -> Preferences -> Evaluation -> Reset
to Defaults rechecked the box next to "Use only textual boxes when
converting input to typeset forms", which of course solved to problem. I
guess I might have unchecked it by mistake. Come to think of it, I should
have made the connection by myself just by reading the option's
description...

Best wishes,
Barak


On Mon, Dec 20, 2010 at 11:20 PM, John Fultz <jfultz@wolfram.com> wrote:

> This is not the behavior I see. What I'm seeing is that the Input style
> leaves
> the following expressions (for example), alone when converted:
>
> Graphics[{Point[{1,1}]}]
> Manipulate[x,{x,0,1}]
> Slider[1]
>
> while the Output style causes them to convert to the graphics and
> interfaces.
> The critical option which is different between the Input and Output styles
> is
> the ShowStringCharacters option. So, for example, this converts to a
> graphic...
>
> Cell["Graphics[{Point[{1,1}]}]","Input",ShowStringCharacters->False]
>
> while this one doesn't...
>
> Cell["Graphics[{Point[{1,1}]}]","Input"]
>
> (and yes, I didn't use the box forms for simplicity, but the same thing is
> true
> for the box forms)
>
> All of this is true for both v7 and v8, so I'm not at all certain that
> upgrading
> to v8 was the actual cause of this for you. Instead, this suggests to me
> that
> you may have an option or stylesheet setting which is unwittingly
> contaminating
> the process. I don't know how much you know about such things and whether
> you
> are likely to have deliberately or accidentally set one of these options.
> An
> easy thing to do would be to reset the FE's preferences, which you can do
> by
> holding Ctrl+Shift while starting Mathematica (or Cmd+Shift on Mac). If
> you
> have any custom settings for the front end, this will clean them out. But
> the
> rogue setting might be specifically on a given notebook or on a stylesheet
> you've created, as well...there are too many possibilities to run down
> without
> getting some more information from you.
>
> Sincerely,
>
> John Fultz
> jfultz@wolfram.com
> User Interface Group
> Wolfram Research, Inc.
>
>
> On Sun, 19 Dec 2010 05:09:56 -0500 (EST), =D7'=D7=A8=D7=A7 =D7=A9=D7=95=

=D7=A9=D7 =D7=E2=84=A2 wrote:
> > Hi everyone,
> >
> > In previous versions of Mathematica, I could use the shortcut Shift-Ctr=

l-
> > N or the menu option Cell -> Convert To -> StandardForm to clean up and
> > format my code, for example, turn x^2 into a real superscript or x/y in=

to
> > a real fraction.
> >
> > However, after upgrading to Mathematica 8, this option also automatical=

ly
> > converts functions such as Manipulate or Slider into the actual output =
of
> > the function. The entire code I wrote for the Manipulate applet becomes
> > the actual applet, and so it's not possible to change the code any more=

.
> > Ctrl-Z, of course, doesn't work, and the only way to get my code back i=
s
> > Shift-Ctrl-I or Cell -> Convert To -> InputForm, which makes it even
> > uglier...
> >
> > This means that I cannot use Shift-Ctrl-N to clean up and format my cod=

e
> > anymore if it contains a Manipulate or any similar function. Usually th=
e
> > converted Manipulate code will not even work after using this option, f=
or
> > example if it depends on variables that have not yet been defined.
> >
> > In conclusion, how can I clean up or format my code without converting
> > the Manipulates? Is there another shortcut or option I can use? Or mayb=

e
> > there's a way to tell Mathematica not to convert the Manipulates?
> >
> > Thank you,
> > Barak

>
>


--20cf30549dafee356c0497de84d2
Content-Type: text/html; charset=windows-1252
Content-Transfer-Encoding: quoted-printable

<div dir="ltr">Thanks for the quick reply!<div><br></div><div>Ctrl-Shift =
did not solve it, but Edit -&gt; Preferences -&gt; Evaluation -&gt; Reset t=
o Defaults rechecked the box next to &quot;Use only textual boxes when conv=
erting input to typeset forms&quot;, which of course solved to problem. I g=
uess I might have unchecked it by mistake. Come to think of it, I should ha=
ve made the connection by myself just by reading the option&#39;s descripti=
on...</div>

<div><br></div><div>Best wishes,</div><div>Barak</div><div><br><br><div cla=
ss="gmail_quote">On Mon, Dec 20, 2010 at 11:20 PM, John Fultz <span dir=
="ltr">&lt;<a href="mailto:jfultz@wolfram.com">jfultz@wolfram.com</a>&g=
t;</span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1p=
x #ccc solid;padding-left:1ex;">This is not the behavior I see. What I&#=
39;m seeing is that the Input style leaves<br>
the following expressions (for example), alone when converted:<br>
<br>
Graphics[{Point[{1,1}]}]<br>
Manipulate[x,{x,0,1}]<br>
Slider[1]<br>
<br>
while the Output style causes them to convert to the graphics and interface=
s.<br>
The critical option which is different between the Input and Output styles =
is<br>
the ShowStringCharacters option. So, for example, this converts to a gra=
phic...<br>
<br>
Cell[&quot;Graphics[{Point[{1,1}]}]&quot;,&quot;Input&quot;,ShowStringChara=
cters-&gt;False]<br>
<br>
while this one doesn&#39;t...<br>
<br>
Cell[&quot;Graphics[{Point[{1,1}]}]&quot;,&quot;Input&quot;]<br>
<br>
(and yes, I didn&#39;t use the box forms for simplicity, but the same thing=
is true<br>
for the box forms)<br>
<br>
All of this is true for both v7 and v8, so I&#39;m not at all certain that =
upgrading<br>
to v8 was the actual cause of this for you. Instead, this suggests to me=
that<br>
you may have an option or stylesheet setting which is unwittingly contamina=
ting<br>
the process. I don&#39;t know how much you know about such things and wh=
ether you<br>
are likely to have deliberately or accidentally set one of these options. =
An<br>
easy thing to do would be to reset the FE&#39;s preferences, which you can =
do by<br>
holding Ctrl+Shift while starting Mathematica (or Cmd+Shift on Mac). If =
you<br>
have any custom settings for the front end, this will clean them out. Bu=
t the<br>
rogue setting might be specifically on a given notebook or on a stylesheet<=
br>
you&#39;ve created, as well...there are too many possibilities to run down =
without<br>
getting some more information from you.<br>
<br>
Sincerely,<br>
<br>
John Fultz<br>
<a href="mailto:jfultz@wolfram.com">jfultz@wolfram.com</a><br>
User Interface Group<br>
Wolfram Research, Inc.<br>
<br>
<br>
On Sun, 19 Dec 2010 05:09:56 -0500 (EST), =D7&#39;=D7=A8=D7=A7 =D7=A9=D7=95=
=D7=A9=D7 =D7=E2=84=A2 wrote:<br>
&gt; Hi everyone,<br>
&gt;<br>
&gt; In previous versions of Mathematica, I could use the shortcut Shift-Ct=
rl-<br>
&gt; N or the menu option Cell -&gt; Convert To -&gt; StandardForm to clean=
up and<br>
&gt; format my code, for example, turn x^2 into a real superscript or x/y i=
nto<br>
&gt; a real fraction.<br>
&gt;<br>
&gt; However, after upgrading to Mathematica 8, this option also automatica=
lly<br>
&gt; converts functions such as Manipulate or Slider into the actual output=
of<br>
&gt; the function. The entire code I wrote for the Manipulate applet become=
s<br>
&gt; the actual applet, and so it&#39;s not possible to change the code any=
more.<br>
&gt; Ctrl-Z, of course, doesn&#39;t work, and the only way to get my code b=
ack is<br>
&gt; Shift-Ctrl-I or Cell -&gt; Convert To -&gt; InputForm, which makes it =
even<br>
&gt; uglier...<br>
&gt;<br>
&gt; This means that I cannot use Shift-Ctrl-N to clean up and format my co=
de<br>
&gt; anymore if it contains a Manipulate or any similar function. Usually t=
he<br>
&gt; converted Manipulate code will not even work after using this option, =
for<br>
&gt; example if it depends on variables that have not yet been defined.<br>
&gt;<br>
&gt; In conclusion, how can I clean up or format my code without converting=
<br>
&gt; the Manipulates? Is there another shortcut or option I can use? Or may=
be<br>
&gt; there&#39;s a way to tell Mathematica not to convert the Manipulates?<=
br>
&gt;<br>
&gt; Thank you,<br>
&gt; Barak<br>
<br>
</blockquote></div><br></div></div>

--20cf30549dafee356c0497de84d2--





Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.