The Last Danish Pastry wrote: > "Richard Tobin" <firstname.lastname@example.org> wrote... > > > In article > > <email@example.com>, > > Brian Chandler <firstname.lastname@example.org> wrote: > > > >>I suppose 'entier' means integer (entier() is the Algol60 function > >>corresponding to floor()) > > > > Do you have any idea why this one function was given a French name? > > I contacted Peter Naur about this word in Algol 60 - he thought that it was > probably already in Algol 58. I then contacted Fredrich Bauer about Algol 58 > and he had no particular recollection about the origin of the term. The > mystery remains.
I've no idea how reliable this claim is, but I remember meeting [ ] and also entier() at a time when I am fairly sure I had never heard of floor(), in um the 60s. It's easy to imagine someone wanting a "different" word for 'integer' for the purposes of naming this function, and simply choosing the French word (IMO).