Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.matlab

Topic: XPC target not able to 'set master to PREOP'
Replies: 5   Last Post: Sep 11, 2013 8:49 AM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
Gordon Weast

Posts: 728
Registered: 12/7/04
Re: XPC target not able to 'set master to PREOP'
Posted: Sep 6, 2013 1:56 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

Nicolas,

We're actively working on the EtherCAT implementation with more
improvements in each release. In R2013b, which is just about available,
you'll be able to stop and restart without redownloading an EtherCAT model.

Unfortunately, we don't have lots of devices to test with. In our
conversations with people at Acontis, they're telling us that ET9000 and
TwinCAT are tolerant of some errors in the device description files.
These same errors won't work with the Acontis stack. We don't have any
full list of what those errors are though but they are things that don't
meet the full published EtherCAT spec.

Please continue to work with MathWorks tech support on these. They will
work with members of our group to debug the problem. We will need to
have you run tests since we probably don't have your device configuration.

Gordon Weast
xPC Target Development
MathWorks

Nicolas wrote:
> Hi Mr Sluiter, Hr Weast,
>
> We have the same error message on xpc Version 5.4 with Matlab r2013a.
>
> Funny thing is, our XPC Ethercat combination works fine for small and
> uncomplicated networks.
> Unfortunately as soons as we have more than two Beckhoff EK1100 (parent
> terms) in our Ethercat network, we get the same error that you have.
>
> We have already submitted a support ticket, but unfortunately not
> received any answers.
> What was the reason of the problems? How did you solve them?
>
> best regards
> Nicolas
>
> "Victor " <v.i.sluiter@utwente.nl> wrote in message
> <ke5m8j$l23$1@newscl01ah.mathworks.com>...

>> Hello,
>>
>> I am trying to get a Beckhoff EtherCAT system working together with an
>> XPC. The EtherCAT system works fine when running from my PC, using the
>> EtherCAT Configurator, and I have exported the settings from the
>> configurator to an XML file for use in Simulink.
>>
>> In Simulink I built a small model, just using the EtherCAT init,
>> EtherCAT Rx Var, EtherCAT tx var, EtherCAT Update and EtherCAT Rx
>> Frames blocks. I can select inputs and outputs in the tx/rx vars blocks.
>> When I build the model I get some warnings about back-inheriting
>> sample time settings, but I guess that's OK.
>>
>> I can succeedingly update the model on my XPC target, which also
>> succeeds, but when I start the model I get the following errors:
>> AT-EM ETherCAT Master V 2.1.2 Build 01 Copyright accntis technologies
>> GmbH
>> Could not set master state to PREOP
>> ERROR: EtherCAT error: No Error
>> System: execution cannot be started
>>
>> I can see no actiivity on the EtherCAT activity LED on the Beckhoff
>> system. The values for 'PCI bus' and 'PCI slot' I used in the EtherCAT
>> Init block are those I got from 'getxpcpci('all')'.
>> Anyone got an idea what might be going wrong?




Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.