Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: MarcumQ function
Replies: 0  

Advanced Search

Back to Topic List Back to Topic List  
Donagh Horgan

Posts: 7
Registered: 4/6/12
MarcumQ function
Posted: May 1, 2013 9:40 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

Hello,

I recently upgraded to Mathematica 9, and I've noticed a problem with the MarcumQ function. The following command should illustrate it:

Plot[{MarcumQ[100, 10, x], 1 - MarcumQ[100, 10, 0, x]}, {x, 0, 30}]

While the two functions are mathematically equivalent, the second incorrectly evaluates to zero between (approximately) x = 14 and x = 17.

The problem only seems to occur when the first parameter is large. For example, the command

Plot[{MarcumQ[50, 10, x], 1 - MarcumQ[50, 10, 0, x]}, {x, 0, 30}]

evaluates correctly, while the command

Plot[{MarcumQ[51, 10, x], 1 - MarcumQ[51, 10, 0, x]}, {x, 0, 30}]

does not.

I've tried wrapping the functions with the N command, e.g. N[f, 100], but the same problem occurs. I've also tried increasing $MaxExtraPrecision and $WorkingPrecision using Block, but with no luck.

I've been testing my old code since I upgraded from Mathematica 8 a few days ago, so the error appears (to me, at least) to be new.

All suggestions greatly appreciated!

Best regards,
Donagh Horgan




Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.