Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: Why can't I solve this ODE set?
Replies: 0  

Advanced Search

Back to Topic List Back to Topic List  
Neo Sherrington

Posts: 1
Registered: 5/19/14
Why can't I solve this ODE set?
Posted: May 19, 2014 2:04 AM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

I tried to use Mathematica to solve this OED set:
DSolve[{y''[r] + (1/r + 2 I p) y'[r] + (-2 h + 2/r - m^2/r^2 - p^2) y[r] ==
2 a z[r],
z''[r] + (1/r - 2 I p) z'[r] + (-2 h + 2/r - m^2/r^2 - p^2) z[r] ==
2 a y[r]},{y,z}r] .
But as I input it, nothing works. Mathematica just give back the same equations to me. Interestingly, either of the 2 equations can be solved separately, including the other in its expression. I mean:
DSolve[y''[r] + (1/r + 2 I p) y'[r] + (-2 h + 2/r - m^2/r^2 - p^2) y[
r] == 2 a z[r], y[r], r]
DSolve[z''[r] + (1/r - 2 I p) z'[r] + (-2 h + 2/r - m^2/r^2 - p^2) z[
r] == 2 a y[r], z[r], r] /. y[r] -> % .
Would anybody please help me, or explain why this phenomenon occurs?




Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.