You are not logged in.
login | register

Discussion: All Topics
Topic: same error in your applet?
Related Item:

Post a new topic to the tool: Polynomial Root Finder App discussion
<< see all messages in this topic
<previous message | next message >

Subject:   Polynomial Roots
Author: Sione
Date: Dec 11 2003

Let me explain the WHY of your question, please bear with me.
I have an applet here at MathForum that does
the polynomial roots:

In my applet the REAL roots (8 decimals) for your equation are:

1) -1.41421356 ( that is '-sqrt(2)' )
2) 1.41421356 ( that is 'sqrt(2)' )

The applet only does REAL roots , COMPLEX roots is
an option to be added in the future.


The precision I used for that applet is 1.490116119384766E-8, that means that
complex number solution that comes up where
the absolute of imaginary part is less than or equal the
precision (which is 1.490116119384766E-8), then
it is counted as a REAL solution.

Now I ran im my machine locally the roots of your
equation :


and the answers came up (including complex number solutions)

1)  -1.41421356   (ie, -sqr(2))
2)  -1 + 3.9484299147897906E-8 * i
3)  -1 - 3.9484299147897906E-8 * i
4)  1.41421356     (ie, sqr(2))

Notice that roots 2 & 3 are conjugate pairs of complex
number roots (meaning plotting them on the complex plane , they reflect each
other along the real-axis). You can SEE clearly WHY my applet missed the  -1
as a real solution because , the ABSOLUTE(3.9484299147897906E-8) or
ABSOLUTE(-3.9484299147897906E-8) are definitely greater than my precision
which is 1.490116119384766E-8 : This leads to the ommision of -1 as a real

When I changed my precision to 5E-8 , I got all the REAL  roots correct, which

1)  -1.41421356   (ie, -sqr(2))
2)  -1
3)  1.41421356     (ie, sqr(2))

This is because ABSOLUTE(3.9484299147897906E-8) or
ABSOLUTE(-3.9484299147897906E-8) is LESS THAN my precision which is 5E-8

Algorithm used:
The alogrithm used in solving ROOTS for polynomial is called  EIGENVALUE
DECOMPOSITION and there is no doubt
that TI-89 used this algorithm too. You can find more about the EIGENVALUE
DECOMPOSITION in many advanced matrix algebra text books or any numerical
analysis books.

Now , I am glad that you brought this issue up, because in the next version of
my polynomial roots applet , I will add a text box so that the user will enter
the PRECISION number themselves, so that the applet can allow any precision
value, instead of being fixed at 1.490116119384766E-8 (default precision).

I have not used  TI-89 before to see whether the functionality allows the user
to specify the precision or not. If this flexibility is not available in TI-89
perhaps, you and others who have bought it bring this issue up with the
manufacturer (I assume it is Texas Instrument). Ask the manufacturer to include
such functionalities (user specified precision) in the next version of TI-89



On Dec 11, 2003, Steve Weimar wrote:

I have the Polynomial Root Finder application (v.1) installed on a TI-89
running OS 2.08. The polynomial that generated the error was

The application seems to graph it correctly but calculated two roots as
non-real. I have the following factorization for the polynomial:

The solve function of the app seemed to miss the -1 root. Can anyone confirm
this and does anyone know why?

The built-in zero functions of the TI-89 seem to get it right. It's the
additional, downloaded application that appears to have an error.

-- steve

Reply to this message          Quote this message when replying?
yes  no
Post a new topic to the tool: Polynomial Root Finder App discussion
Visit related discussions:
Polynomial Root Finder App tool
Texas Instruments

Discussion Help