Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: parametric plot and filling
Replies: 9   Last Post: Aug 23, 2013 4:56 AM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
Bob Hanlon

Posts: 906
Registered: 10/29/11
Re: parametric plot and filling
Posted: Aug 22, 2013 12:47 AM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply


I also noticed that Solve does not need the Thread. This also works:

Plot[Evaluate[y /. {
Solve[{x, y} == {2 t, -t^2}, {y, t}],
Solve[{x, y} == {6 + 2 t, -t^2}, {y, t}]}],
{x, -4, 10},
Axes -> {True, False},
Ticks -> None,
PlotStyle ->
{{Thick, Cyan}, {Thick, Green}},
PlotRange -> {-4, 0},
AspectRatio -> 0.285714,
Filling -> -4]



Bob Hanlon




On Wed, Aug 21, 2013 at 1:58 AM, Bob Hanlon <hanlonr357@gmail.com> wrote:

>
> I would try to convert it to a standard plot.
>
>
> ParametricPlot[
> {{2 t, -t^2}, {6 + 2 t, -t^2}},
> {t, -2, 2},
> Axes -> {True, False},
> Ticks -> None,
> PlotStyle -> {{Thick, Cyan}, {Thick, Green}}]
>
>
> Plot[
> Evaluate[y /. {
> Solve[Thread[
> {x, y} == {2 t, -t^2}], {y, t}],
> Solve[Thread[
> {x, y} == {6 + 2 t, -t^2}], {y, t}]}],
> {x, -4, 10},
> Axes -> {True, False},
> Ticks -> None,
> PlotStyle -> {{Thick, Cyan}, {Thick, Green}},
> PlotRange -> {-4, 0},
> AspectRatio -> 0.285714,
> Filling -> -4]
>
>
>
> Bob Hanlon
>
>
>
>
> On Tue, Aug 20, 2013 at 7:36 AM, Francisco Gutierrez <
> fgutiers2002@yahoo.com

> > wrote:
>
> >
> > Dear group:
> >
> > DoesParametricPlot admit the Filling option? Seems it not? How then to
> > perform it?
> > Lokk at the following simple example:
> >
> > ParametricPlot[{{2 t,-t^2},{6+ 2 t,-t^2}}, {t,-2,2},Axes->{True,False},
> > Ticks->None, PlotStyle->{{Thick,Cyan},{Thick,Green}}]
> >
> >
> >
> > The if I introduce the Filling command inside PlotStyle nothing happens,
> > and outside it produces an error. Any ideas?
> > francisco
> >

>
>
>






Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.