Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: wrong result when computing a definite integral
Replies: 3   Last Post: Jan 11, 2013 10:24 PM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
liquid.phynix@gmail.com

Posts: 2
Registered: 12/17/08
wrong result when computing a definite integral
Posted: Jan 10, 2013 9:38 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

hi group,

i run into this problem today when giving a bunch of easy integrals to mathematica.
here's a wolfram alpha link to the problem:
http://www.wolframalpha.com/input/?i=Integrate%5BExp%5BI+Sqrt%5B3%5Dy%5D%2C%7Bx%2C-2Pi%2C2Pi%7D%2C%7By%2C-Pi%2CPi%7D%5D#

the integrand does not depend on the 'x' variable, the inner integration should only result in a factor of 4Pi, and the correct result is a real number, yet the below integral gives a complex number which is far off from the correct value:
Integrate[Exp[I Sqrt[3] y], {x, -2 Pi, 2 Pi}, {y, -Pi, Pi}] -> -((4 I (-1 + E^(2 I Sqrt[3] Pi)) Pi)/Sqrt[3])

from some trial and error it seems the result is also incorrect for non-integer factors in the exponential.




Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.