Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: A bug-looking behavior during integration
Replies: 2   Last Post: Mar 3, 2013 10:58 PM

Advanced Search

Back to Topic List Back to Topic List Jump to Tree View Jump to Tree View   Messages: [ Previous | Next ]
Alexei Boulbitch

Posts: 483
Registered: 2/28/08
A bug-looking behavior during integration
Posted: Feb 27, 2013 11:42 PM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

Dear community,

I would like to report a strange behaviour, that looks most of all like a bug.

The integral of the UnitStep of some function

Integrate[
UnitStep[Sqrt[Sqrt[x^2 + y^2] + x] -
0.7 Sqrt[x^2 + y^2]], {x, -Infinity, Infinity}, {y, -Infinity,Infinity}]

0

returns zero as you see, though the function under the integral is 1 within some domain in the form of a cardioid, and zero outside of it. To make it sure evaluate this:

Plot3D[UnitStep[
Sqrt[Sqrt[x^2 + y^2] + x] - 0.7 Sqrt[x^2 + y^2]], {x, -3, 5}, {y, -3, 5}]

The integral must be positive, therefore.

Taking the numerical value of the same integral one finds a finite positive value:

NIntegrate[
UnitStep[Sqrt[Sqrt[x^2 + y^2] + x] -
0.7 Sqrt[x^2 + y^2]], {x, -Infinity, Infinity}, {y, -Infinity, Infinity}]

19.6268

Is it indeed a bug?

Regards, Alexei


Alexei BOULBITCH, Dr., habil.
IEE S.A.
ZAE Weiergewan,
11, rue Edmond Reuter,
L-5326 Contern, LUXEMBOURG

Office phone : +352-2454-2566
Office fax: +352-2454-3566
mobile phone: +49 151 52 40 66 44

e-mail: alexei.boulbitch@iee.lu







Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.