Drexel dragonThe Math ForumDonate to the Math Forum



Search All of the Math Forum:

Views expressed in these public forums are not endorsed by Drexel University or The Math Forum.


Math Forum » Discussions » Software » comp.soft-sys.math.mathematica

Topic: Format expression in TeXForm not working
Replies: 0  

Advanced Search

Back to Topic List Back to Topic List  
Yi Wang

Posts: 33
Registered: 3/30/12
Format expression in TeXForm not working
Posted: Jan 18, 2014 5:04 AM
  Click to see the message monospaced in plain text Plain Text   Click to reply to this topic Reply

Hello,

I am trying to format some expressions into TeXForm. To get started, I found this example on the last entry of "tutorial/DefiningOutputFormats" of Mathematica documentation:

Format[x, TeXForm] := "{\\bf x}"

However, it does not work as desired. When I run

x // TeXForm

the output is

\text {$\{\backslash \backslash $bf x$\} $}

Instead of {\\bf x}.

Is it my problem or the documentation needs to be updated?

====== The expression I want to format ======

I was trying to format Pd[f, {0}] to \dot{f} and Pd[f, {0, 0}] to \ddot{f}. I guess it should be similar to the above example, if it works at all.

====== Mathematica Version ======

In[28]:= $Version

Out[28]= "9.0 for Linux x86 (64-bit) (February 7, 2013)"




Point your RSS reader here for a feed of the latest messages in this topic.

[Privacy Policy] [Terms of Use]

© Drexel University 1994-2014. All Rights Reserved.
The Math Forum is a research and educational enterprise of the Drexel University School of Education.